BMW E60 5-Series Forum | 5Post.com  
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  

Go Back   BMW E60 5-Series Forum | 5Post.com > BMW 5-Series (E60) Forums (2004 - 2009) > General 5-series (E60) Forum

Post Reply
 
Thread Tools Search this Thread
      06-16-2012, 11:16 AM   #1
ekr059
Registered
 
Drives: 2004 BMW 545i
Join Date: Aug 2010
Location: Canada

Posts: 2
iTrader: (0)

545i frustrating code problems

Hi,

I'm new to these forums so I apologize if this isn't in the right spot. Also, I know very little about cars/mechanics, so forgive my ignorance as I try to explain what's been going on with this car.

I bought my 2004 545i almost a year ago and since I got it I've had a lot of problems with codes coming up. I've been consistently getting 'your engine has overheated...' and 'your engine temperature is too hot...' messages. These come up on the iDrive for just long enough for me to read them and then they'll disappear. I do a systems check and it says 'all systems ok'. I've had it in at my mechanics a few times for that and they say it doesn't come up on their code reader and there doesn't seem to be anything mechanically wrong with the car. I've got one about a rear backup light malfunction but I've never had anyone in the car with me to check if there was actually a problem or not at the time. That one stays up the whole time the car is on but the next time I start it it's gone. Starting about two weeks ago the 'active steering malfunction' code has started coming up on the iDrive (and staying on). This has been coming up every 4 or 5 times I drive the car.

Then a couple days ago I parked the car at work and when I got back at the end of the day my hazard lights were on and the battery was dead. The car is now turning on/off the hazards sporadically. I'm not sure if this would've been what killed the battery or if it was something else. When the car is turned off pressing the hazard light button will turn the hazards off after they've turned themselves on. But when the car is started that button has no effect. And it seems to be tied to the brakes/brake lights somehow - when I'm stopped at a light they'll be off, but then I release the brake and they go on. Then I tap the brakes and they go off again. Anyway, I took it to my mechanic again yesterday and they checked the battery and alternator and said they both looked fine. They said that when they read the codes there were a ton of them and they're thinking it's something they can't fix. They said that the computer might either need reprogramming or replacement. I'm not sure what computer they're talking about. I've been trying to research the computer systems in these cars and I'm at a loss. I've seen the acronyms ECU, TCU, EWS, and DME. Does anyone know what would control the kinds of codes I'm talking about or how this stuff works? I'm a computer programmer for a living so I think I'd feel better if I understood a little bit more about what's been going on in this frustrating car.

Has anyone experienced problems like these? The car is at the dealership now waiting for them to take a look at it and I'd like to know what some of the possible problems/options could be before they tell me I need to replace something really expensive. Any comments/advice would be greatly appreciated. I've dreamed about owning a 5 series for over a decade and the first one (and possibly last) is not turning out so well.

Thanks,

Ellen
ekr059 is offline  
0
Reply With Quote
      06-17-2012, 09:30 AM   #2
Alpha989c
Registered
 
Drives: 528xi
Join Date: May 2012
Location: Brooklyn NY

Posts: 3
iTrader: (0)

Hey it sound like you have a low voltage problem, wich results in a bad battery, your mechanic doesn't have the right type of scanner to actually see whats wrong with the car so my suggestion is to spend the 300$ at the dealer, 100 for diagnosis and the 200 for battery replacement and plus they will tell you if you need additional software to be programmed, they sometimes come out with updates, Hope this helps.
Alpha989c is offline  
0
Reply With Quote
Post Reply

Bookmarks

Tags
545, codes, computer system, hazard lights

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 05:33 AM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST