BMW E60 5-Series Forum | 5Post.com  
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  

Go Back   BMW E60 5-Series Forum | 5Post.com > BMW 5-Series (E60) Forums (2004 - 2009) > General 5-series (E60) Forum

Post Reply
 
Thread Tools Search this Thread
      01-07-2011, 04:17 PM   #1
jvilla
New Member
 
Drives: 07 550i
Join Date: Sep 2010
Location: Texas

Posts: 7
iTrader: (0)

Question 07 550i iDrive Out, Seeking Help - adventures with Mechanic & Dealership

Hello,
Having some issues with my iDrive on my 2007 550i e60 that is no longer on warranty. I've dealt with independent mechanics, buying a battery, doing tests, then alternative was supposedly bad, then software issues, and now about to deal with dealership. Let me explain what happened and the events.

a little under a month ago my idrive system was acting up. It would just shut off while driving, and then turn back on sometimes while driving or after restart. After a couple of days it just stopped coming on entirely. I researched online but there were different theories. So I lived with it for a bit, didn't want to spend christmas money on it at the time. Then after a point where I didn't drive it for a day or so the car would not start. I figured, yea its the battery, well thats better problem to have than the idrive system going out. I finally take it into an independent BMW mechanic, good people, highly rated. he says it is the battery and charges me half the cost that the dealer would charge. I happily pay that and drive off the lot. iDrive system is on and life seems great. After a couple of miles down the road, the idrive system shuts off again and never came back on after that. I took it back to mechanic. He says they'll run some more tests on the battery and can't seem to really find the problem but said something is causing it to fluctuate and he's pretty positive it was the alternator. Would cost about $600 for the part and 2hrs ($90/hr) for labor. Sounded about right. Though I know I can get the part myself (exact one) for about $350 online. Any how I had to wait on that and I wanted to get second opinion since he just assumed it was the alternator. He tells me I can drive around like this until the battery is no longer holding a charge or alternator goes out completely. I go ahead and wait and drive the car with no issues but still have no idrive (navigation, lcd, music, audio).

So just a couple of days ago the car wont start again. The battery is dead. I didn't drive it for about 2 days. I get it jumped and take it to knew mechanic who's going to run a test on it. He says the battery and alternator are fine. So they put it on another machine and find an error code about the car not going into hibernation mode when you turn it off. The documentation says something like: "Vehicle does not always go to sleep. Has communication issues. Might need software updates." So the computer or some electronics are not turning off and draining the batter all the time. He says it can very well be a software bug or issue and probably needs software updates from the dealership. Depending on how long its been since its updated, it can take an hour or even stay all day on the computer doing updates costing from either $100 to $500 for the updates. He said it should also fix the idrive not coming back on.

Now my questions or thoughts:
- why hasn't the idrive turned back on after each jump or charge. I'd hate to think the iDrive is fried cause that is a huge cost.
- I think i read somewhere that there is a recall or service bulletin about the car electronics not shutting off and draining the battery but I can't seem to find it again. Any one hear about this?
- Does anyone have experience with dealership doing software updates? How long does it take. what did it cost, what did it fix or improve?
- Anybody have issues with idrive not turning back on and finding a software update or fuse might have fixed it?

Any insight would be greatly appreciated as I am seeing the dealership this coming monday.
Thanks
-JV
jvilla is offline  
0
Reply With Quote
      01-08-2011, 04:45 PM   #2
jasperxli
Private First Class
 
Drives: space grey e60
Join Date: Sep 2010
Location: socal

Posts: 152
iTrader: (2)

a members on forums.5series.net had the same problem. http://forums.5series.net/topic/1068...3#entry1271873
jasperxli is offline  
0
Reply With Quote
      01-11-2011, 01:00 AM   #3
jvilla
New Member
 
Drives: 07 550i
Join Date: Sep 2010
Location: Texas

Posts: 7
iTrader: (0)

**** UPDATE *****

Thanks Jasper, I was referred to that also... going to get some input from there also.

I took my vehicle into the dealership this morning. Of course the battery was dead so I had to jump start it and the steering was TIGHT, apparently the servotronic (or whatever is handling the steering was out, probably from battery being dead). I still managed to get to the dealership where they said the servotronic was malfunctioning. They did fix the recalled brake pump situation. They said my terminal was lose and that might fix some of my issues. After picking it up, the car is running fine (for now), the steering wasn't tight like when I drove it in this morning, so that is back. But iDrive is still not running and I'm sure the issue the battery will keep draining. The did give me a laundry list of things they found that needs to be fixed. I'm going to try to get that list and see whats most urgent and get second estimates on them..

So for my next posting, I'm going to try to find any recommendations for a mechanic here in Houston that can run tests and see what if anything is wrong with my iDrive system. I'm sure there is a way to find out if its one component or several. I'm hoping the former of course. I'll go to the dealership as last option but I'm worried they are just going to overlook it and say the whole iDrive system needs to be replaced (all components).
jvilla is offline  
0
Reply With Quote
      01-30-2011, 09:47 PM   #4
Tom Train
New Member
 
Drives: 545i
Join Date: Jan 2011
Location: St. Paul, MN

Posts: 5
iTrader: (0)

I had the same issue on my 2004. Unfortunately it lead to the idrive screen being replaced. About a $1200 repair that was luckily under CPO warranty.

Prior to that they tried to update some software and such, didn't work. Took 3 times in the shop for them to finally replace the idrive which had also been replaced in 2006 prior to my owning of the car.

I have no idea of the screen and the idrive are all-in-one, or separate, regardless I seem to recall the screen being the culprit and affecting the whole system.
Tom Train is offline  
0
Reply With Quote
      07-19-2011, 02:29 PM   #5
jvilla
New Member
 
Drives: 07 550i
Join Date: Sep 2010
Location: Texas

Posts: 7
iTrader: (0)

Buying a CCC Unit.. question about this...

after several months with out radio and gps I'm finally going to step up and get this system fixed. I was thinking about buying this one: http://cgi.ebay.com/ebaymotors/ws/eB...m=160547937513
Seller says it will work in my e60 2007 550i but the volume knob looks a bit off. He still says its not a problem. Im getting my local mechanic to install this system. This would include the computer, knobs, disc drives and LCD. My questions are this:
  • What can I do with the old part. Surely it has some value, LCD, CCC or other items. Anyone recommend anything about this? I do not have to return as core.
  • Has anyone purchased a CCC unit and if so can you share your experience with installing and reprogramming them? Where did you get yours from?

Thanks!
jvilla is offline  
0
Reply With Quote
Post Reply

Bookmarks

Tags
550i, electronics, hibernation, idrive, sleep

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:22 AM.




5post
Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST