BMW E60 5-Series Forum | 5Post.com  
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  

Go Back   BMW E60 5-Series Forum | 5Post.com > BMW 5-Series (E60) Forums (2004 - 2009) > General 5-series (E60) Forum

Post Reply
 
Thread Tools Search this Thread
      01-20-2022, 01:05 PM   #1
npgraphicdesign
Registered
0
Rep
2
Posts

Drives: Scion TC
Join Date: Nov 2021
Location: CT

iTrader: (0)

Right low beam malfunction - 2010 BMW 5-Series 528i

So, I just bought this about 2 months ago.

2010 BMW 5-Series 528i with xDrive
6sp manual
Just over 140k miles

This error just came up today - right low beam malfunction. My question is:

1. Is it just a bulb issue, and if so, is this something I can replace on my own?
2. I would love to get brighter low (and hi) bulbs to replace the factor ones, as they are quite dull. Any recommendations on brighter bulbs that I could replace all around?
3. The message 'service required' came on - is this because of the low beam malfunction or possibly something else? I had a post-buy inspection done at a specialty BMW shop in CT, and they fixed quite a few things, checked all fluids/hoses/etc., so I'm not sure if it could be something else that just came up since I had it in the shop, or if it's just to indicate that the beam needs to be fixed?

Thanks in advance everyone! I just got this car, and it (and the BMW community) is brand new to me.
Attached Images
   
Appreciate 0
      01-20-2022, 06:10 PM   #2
JayArras
Casual Fanatic
25
Rep
169
Posts

Drives: '07 530xi
Join Date: Oct 2010
Location: Fairfield County, CT

iTrader: (0)

These threads may help you diagnose:

https://5series.net/forums/e60-discu...nction-103407/

https://5series.net/forums/e60-discu...5281-a-137638/

The "Service Required" message is different. Go into your iDrive to determine which service is needed. I'm surprised that the place that did your post-purchase inspection didn't take care of whatever it is (unless by coincidence, it just happened to pop up after.)
__________________
2007 530xi, Black Metallic Sapphire, 6 speed manual, Sport package, Cold Weather Package, Premium Package, Premium Sound Package, Sirius Satellite Radio, MTech front bumper, Replica Style 166 wheels
Appreciate 0
      01-21-2022, 02:29 PM   #3
npgraphicdesign
Registered
0
Rep
2
Posts

Drives: Scion TC
Join Date: Nov 2021
Location: CT

iTrader: (0)

Quote:
Originally Posted by JayArras View Post
These threads may help you diagnose:

https://5series.net/forums/e60-discu...nction-103407/

https://5series.net/forums/e60-discu...5281-a-137638/

The "Service Required" message is different. Go into your iDrive to determine which service is needed. I'm surprised that the place that did your post-purchase inspection didn't take care of whatever it is (unless by coincidence, it just happened to pop up after.)
Thanks Jay! I appreciate it
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 07:48 AM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST