BMW E60 5-Series Forum | 5Post.com  
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  

Go Back   BMW E60 5-Series Forum | 5Post.com > BMW 5-Series (E60) Forums (2004 - 2009) > General 5-series (E60) Forum

Post Reply
 
Thread Tools Search this Thread
      10-25-2013, 06:11 AM   #1
tanzilees
New Member
3
Rep
5
Posts

Drives: E61 LCI 520d
Join Date: Nov 2012
Location: Gosport

iTrader: (0)

PLEASE HELP 2008 E61 LCI Power Loss Suspect DPF/EGR??

I have a 2008 520d lci and it has suddenly started to lose power, I plugged in a fault code reader and was given the code P14A1 looking online I believe this is the exhaust gas backpressure sensor, or possible DPF filter failure. does anyone have any ways of to fix this problem? I have been told if I want to fit a new egr then it had to be recoded an is not a plug in and play item! Does anyone know how to code a new egr or any tips on fixing this problem! Need help ASAP!! Thanks all!
Tanzi
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 03:28 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST