BMW E60 5-Series Forum | 5Post.com  
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read  

Go Back   BMW E60 5-Series Forum | 5Post.com > BMW 5-Series (E60) Forums (2004 - 2009) > General 5-series and M5 (E60) Forum

Post Reply
 
Thread Tools Search this Thread
      09-28-2023, 01:42 AM   #1
n54boost
Registered
0
Rep
1
Posts

Drives: BMW 535
Join Date: Sep 2023
Location: usa

iTrader: (0)

Fuel low pressure sensor pinned at 89psi

2009 535i - Been having this fuel issue where my fuel pressure psi will get pinned to a set number my specific issue it gets pinned around 89-90psi, when the car starts like this within a few minutes of driving or idle it will go into limp mode. this is not all the time, I can get my car to start and run well with no pinned number, after several times restarting the car. Also, I am not getting any codes. Any who...

Everything I have tried so far:

-New low-pressure sensor
-complete low-pressure fuel system (just upgraded to Fuelit stage 2 pump. New buckets line everything)
-New EKPM3 (I did code it)
-New High-pressure fuel pump, but an Amazon special so I'm thinking the problem is it's from this sh*tty Amazon pump and I just need fork the $1100 for one off FCP

please Lmk what yall think
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 06:30 PM.




5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST